What’s Vulnerable › Vulnerabilities
CVE-2024-5906: Prisma Cloud Compute: Stored Cross-Site Scripting (XSS) Vulnerability in the Web Interface
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-12 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability in Palo Alto Networks Prisma Cloud Compute software enables a malicious administrator with add/edit permissions for identity providers to store a JavaScript payload using the web interface on Prisma Cloud Compute. This enables a malicious administrator to perform actions in the context of another user's browser when accessed by that other user.
Affected products
- Palo Alto Networks Prisma Cloud Compute: before 32.05.124 — fixed in 32.05.124
- Palo Alto Networks Prisma Cloud Compute: from 32 before 32.05 — fixed in 32.05
- Palo Alto Networks Prisma Cloud Compute: from 32 before 32.05 (O’Neal - Update 5) — fixed in 32.05 (O’Neal - Update 5)
How to fix
Upgrade to a fixed version: Palo Alto Networks Prisma Cloud Compute 32.05.124; Palo Alto Networks Prisma Cloud Compute 32.05; Palo Alto Networks Prisma Cloud Compute 32.05 (O’Neal - Update 5). Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2024-5906
- https://security.paloaltonetworks.com/CVE-2024-5906
Get alerted when CVE-2024-5906 or the next vulnerability affects your stack