What’s Vulnerable › Vulnerabilities
CVE-2024-5918: PAN-OS: Improper Certificate Validation Enables Impersonation of a Legitimate GlobalProtect User
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-14 · updated 2026-06-17
- Weakness: CWE-295
Description
An improper certificate validation vulnerability in Palo Alto Networks PAN-OS software enables an authorized user with a specially crafted client certificate to connect to an impacted GlobalProtect portal or GlobalProtect gateway as a different legitimate user. This attack is possible only if you "Allow Authentication with User Credentials OR Client Certificate."
Affected products
- Palo Alto Networks PAN-OS: from 10.1.0 before 10.1.11; from 10.2.0 through 10.2.4; from 11.0.0 before 11.0.3; 10.2.4-h2, 10.2.4-h3, 10.2.4-h4; 10.2.4 — fixed in 10.1.11, 11.0.3
- Palo Alto Networks PAN-OS: from 11.0.0 before 11.0.3; from 10.2.0 before 10.2.4-h5; from 10.1.0 before 10.1.11 — fixed in 11.0.3, 10.2.4-h5, 10.1.11
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 10.1.11, 11.0.3; Palo Alto Networks PAN-OS 11.0.3, 10.2.4-h5, 10.1.11. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-5918 or the next vulnerability affects your stack