What’s Vulnerable › Vulnerabilities
CVE-2024-5920: PAN-OS: Stored Cross-Site Scripting (XSS) Vulnerability in PAN-OS Enables Impersonation of a Legitimate Administrator
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-14 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability in Palo Alto Networks PAN-OS software enables an authenticated read-write Panorama administrator to push a specially crafted configuration to a PAN-OS node. This enables impersonation of a legitimate PAN-OS administrator who can perform restricted actions on the PAN-OS node after the execution of JavaScript in the legitimate PAN-OS administrator's browser.
Affected products
- Palo Alto Networks PAN-OS: from 10.1.0 before 10.1.14; from 10.2.0 before 10.2.11; from 11.0.0 before 11.0.6; from 11.1.0 before 11.1.4 — fixed in 10.1.14, 10.2.11, 11.0.6, 11.1.4
- Palo Alto Networks PAN-OS: from 11.1.0 before 11.1.4; from 11.0.0 before 11.0.6; from 10.2.0 before 10.2.7-h24; from 10.1.0 before 10.1.14 — fixed in 11.1.4, 11.0.6, 10.2.7-h24, 10.2.10-h14, 10.2.11, 10.1.14
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 10.1.14, 10.2.11, 11.0.6, 11.1.4; Palo Alto Networks PAN-OS 11.1.4, 11.0.6, 10.2.7-h24, 10.2.10-h14. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-5920 or the next vulnerability affects your stack