What’s Vulnerable › Vulnerabilities
CVE-2024-5921: GlobalProtect App: Insufficient Certificate Validation Leads to Privilege Escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-27 · updated 2026-06-17
- Weakness: CWE-295
Description
An insufficient certification validation issue in the Palo Alto Networks GlobalProtect app enables attackers to connect the GlobalProtect app to arbitrary servers. This can enable a local non-administrative operating system user or an attacker on the same subnet to install malicious root certificates on the endpoint and subsequently install malicious software signed by the malicious root certificates on that endpoint. Please subscribe to our RSS feed https://security.paloaltonetworks.com/rss.xml to be alerted to new updates to this and other advisories.
Affected products
- Palo Alto Networks GlobalProtect App: from 6.1.0 before 6.1.6; from 6.1.0 before 6.1.7; from 6.1.0 before 6.2.1; from 6.1.0 before 6.2.6; from 6.3.0 before 6.3.2 — fixed in 6.1.6, 6.1.7, 6.2.1, 6.2.6, 6.3.2
- Palo Alto Networks GlobalProtect App: from 6.3.0 before 6.3.2; from 6.2.0 before 6.2.6; 6.1.0 — fixed in 6.3.2, 6.2.6
How to fix
Upgrade to a fixed version: Palo Alto Networks GlobalProtect App 6.1.6, 6.1.7, 6.2.1, 6.2.6; Palo Alto Networks GlobalProtect App 6.3.2, 6.2.6. Check the vendor advisory for mitigations.
References
- https://blog.amberwolf.com/blog/2024/november/palo-alto-globalprotect---code-execution-and-privilege-escalation-via-malicious-vpn-server-cve-2024-5921/
- https://github.com/AmberWolfCyber/NachoVPN
- https://security.paloaltonetworks.com/CVE-2024-5921
Get alerted when CVE-2024-5921 or the next vulnerability affects your stack