What’s Vulnerable › Vulnerabilities
CVE-2024-5942: Page and Post Clone <= 6.0 - Insecure Direct Object Reference to Authenticated (Author+) Sensitive Information Exposure
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-29 · updated 2026-06-17
- Weakness: CWE-639
Description
The Page and Post Clone plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 6.0 via the 'content_clone' function due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with Author-level access and above, to clone and read private posts.
Affected products
- carlosfazenda Fast Page & Post Duplicator: before 6.1 — fixed in 6.1
How to fix
Upgrade to a fixed version: carlosfazenda Fast Page & Post Duplicator 6.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/page-or-post-clone/trunk/page-or-post-clone.php#L19
- https://plugins.trac.wordpress.org/changeset/3108149/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0931f279-2dac-4663-9344-df27b43a7e64?source=cve
- https://plugins.trac.wordpress.org/browser/page-or-post-clone/trunk/page-or-post-clone.php#L19
- https://plugins.trac.wordpress.org/changeset/3108149/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0931f279-2dac-4663-9344-df27b43a7e64?source=cve
Get alerted when CVE-2024-5942 or the next vulnerability affects your stack