What’s Vulnerable › Vulnerabilities
CVE-2024-5943: Nested Pages <= 3.2.7 - Cross-Site Request Forgery to Local File Inclusion
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-04 · updated 2026-06-17
- Weakness: CWE-352
Description
The Nested Pages plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.2.7. This is due to missing or incorrect nonce validation on the 'settingsPage' function and missing santization of the 'tab' parameter. This makes it possible for unauthenticated attackers to call local php files via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- Nested Pages: before 3.2.8 — fixed in 3.2.8
How to fix
Upgrade to a fixed version: Nested Pages 3.2.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-nested-pages/trunk/app/Config/Settings.php#L129
- https://plugins.trac.wordpress.org/browser/wp-nested-pages/trunk/app/Views/settings/settings.php#L20
- https://plugins.trac.wordpress.org/changeset/3111847/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c2663150-61f9-49e3-9219-fbe89cc6b03c?source=cve
- https://plugins.trac.wordpress.org/browser/wp-nested-pages/trunk/app/Config/Settings.php#L129
- https://plugins.trac.wordpress.org/browser/wp-nested-pages/trunk/app/Views/settings/settings.php#L20
- https://plugins.trac.wordpress.org/changeset/3111847/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c2663150-61f9-49e3-9219-fbe89cc6b03c?source=cve
Get alerted when CVE-2024-5943 or the next vulnerability affects your stack