What’s Vulnerable › Vulnerabilities
CVE-2024-5973: MasterStudy LMS < 3.3.24 - Privilege Escalation to Instructor
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-22 · updated 2026-06-17
Description
The MasterStudy LMS WordPress Plugin WordPress plugin before 3.3.24 does not prevent students from creating instructor accounts, which could be used to get access to functionalities they shouldn't have.
Affected products
- MasterStudy LMS WordPress Plugin: before 3.3.24 — fixed in 3.3.24
How to fix
Upgrade to a fixed version: MasterStudy LMS WordPress Plugin 3.3.24. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/59abfb7c-d5ea-45f2-ab9a-4391978e3805/
- https://wpscan.com/vulnerability/59abfb7c-d5ea-45f2-ab9a-4391978e3805/
Get alerted when CVE-2024-5973 or the next vulnerability affects your stack