What’s Vulnerable › Vulnerabilities
CVE-2024-5974: Firebox Authenticated Buffer Overflow Vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-09 · updated 2026-08-07
- Weakness: CWE-120
Description
A buffer overflow in WatchGuard Fireware OS could may allow an authenticated remote attacker with privileged management access to execute arbitrary code with system privileges on the firewall. This issue affects Fireware OS: from 11.9.6 through 12.10.3.
Affected products
- WatchGuard Fireware OS: from 11.9.4 before 12.5.12; from 12.6 before 12.10.4; 12.5.12-u1 — fixed in 12.10.4, 12.5.12
How to fix
Upgrade to a fixed version: WatchGuard Fireware OS 12.10.4, 12.5.12. Check the vendor advisory for mitigations.
References
- https://psirt.watchguard.com/CVE-2024-5974
- https://www.watchguard.com/wgrd-psirt/advisory/wgsa-2024-00011
- https://www.watchguard.com/wgrd-psirt/advisory/wgsa-2024-00011
Get alerted when CVE-2024-5974 or the next vulnerability affects your stack