What’s Vulnerable › Vulnerabilities
CVE-2024-5980: Arbitrary File Write via /v1/runs API endpoint in lightning-ai/pytorch-lightning
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-27 · updated 2026-06-17
- Weakness: CWE-22
Description
A vulnerability in the /v1/runs API endpoint of lightning-ai/pytorch-lightning v2.2.4 allows attackers to exploit path traversal when extracting tar.gz files. When the LightningApp is running with the plugin_server, attackers can deploy malicious tar.gz plugins that embed arbitrary files with path traversal vulnerabilities. This can result in arbitrary files being written to any directory in the victim's local file system, potentially leading to remote code execution.
Affected products
- lightning-ai/pytorch-lightning: from 2.2.4 before 2.3.3 — fixed in 2.3.3
How to fix
Upgrade to a fixed version: lightning-ai/pytorch-lightning 2.3.3. Check the vendor advisory for mitigations.
References
- https://github.com/lightning-ai/pytorch-lightning/commit/330af381de88cff17515418a341cbc1f9f127f9a
- https://huntr.com/bounties/55a6ac6f-89c7-42ea-86f3-c6e93a2679f3
- https://huntr.com/bounties/55a6ac6f-89c7-42ea-86f3-c6e93a2679f3
Get alerted when CVE-2024-5980 or the next vulnerability affects your stack