What’s Vulnerable › Vulnerabilities
CVE-2024-5988: Rockwell Automation ThinManager® ThinServer™ Improper Input Validation Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-25 · updated 2026-06-17
- Weakness: CWE-20
Description
Due to an improper input validation, an unauthenticated threat actor can send a malicious message to invoke a local or remote executable and cause a remote code execution condition on the Rockwell Automation ThinManager® ThinServer™.
Affected products
- Rockwell Automation ThinManager ThinServer: from 11.1.0 before 11.1.8; from 11.2.0 before 11.2.9; from 12.0.0 before 12.0.7; from 12.1.0 before 12.1.8; from 13.0.0 before 13.0.5; from 13.1.0 before 13.1.3 — fixed in 11.1.8, 11.2.9, 12.0.7, 12.1.8, 13.0.5, 13.1.3
- Rockwellautomation Thinserver: from 11.1.0 before 11.1.8; from 11.2.0 before 11.2.9; from 12.0.0 before 12.0.7; from 12.1.0 before 12.1.8; from 13.0.0 before 13.0.5; from 13.1.0 before 13.1.3 — fixed in 11.1.8, 11.2.9, 12.0.7, 12.1.8, 13.0.5, 13.1.3
How to fix
Upgrade to a fixed version: Rockwell Automation ThinManager ThinServer 11.1.8, 11.2.9, 12.0.7, 12.1.8; Rockwellautomation Thinserver 11.1.8, 11.2.9, 12.0.7, 12.1.8. Check the vendor advisory for mitigations.
References
- https://www.rockwellautomation.com/en-us/trust-center/security-advisories/advisory.SD1677.html
- https://www.rockwellautomation.com/en-us/trust-center/security-advisories/advisory.SD1677.html
Get alerted when CVE-2024-5988 or the next vulnerability affects your stack