What’s Vulnerable › Vulnerabilities
CVE-2024-5990: ThinManager® ThinServer™ Improper Input Validation Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-25 · updated 2026-06-17
- Weakness: CWE-20
Description
Due to an improper input validation, an unauthenticated threat actor can send a malicious message to a monitor thread within Rockwell Automation ThinServer™ and cause a denial-of-service condition on the affected device.
Affected products
- Rockwell Automation ThinManager ThinServer: from 11.1.0 before 11.1.8; from 11.2.0 before 11.2.9; from 12.0.0 before 12.0.7; from 12.1.0 before 12.1.8; from 13.0.0 before 13.0.4; from 13.1.0 before 13.1.2 — fixed in 11.1.8, 11.2.9, 12.0.7, 12.1.8, 13.0.4, 13.1.2
- Rockwellautomation Thinserver: from 11.1.0 before 11.1.8; from 11.2.0 before 11.2.9; from 12.0.0 before 12.0.7; from 12.1.0 before 12.1.8; from 13.0.0 before 13.0.4; from 13.1.0 before 13.1.2 — fixed in 11.1.8, 11.2.9, 12.0.7, 12.1.8, 13.0.4, 13.1.2
How to fix
Upgrade to a fixed version: Rockwell Automation ThinManager ThinServer 11.1.8, 11.2.9, 12.0.7, 12.1.8; Rockwellautomation Thinserver 11.1.8, 11.2.9, 12.0.7, 12.1.8. Check the vendor advisory for mitigations.
References
- https://www.rockwellautomation.com/en-us/trust-center/security-advisories/advisory.SD1677.html
- https://www.rockwellautomation.com/en-us/trust-center/security-advisories/advisory.SD1677.html
Get alerted when CVE-2024-5990 or the next vulnerability affects your stack