What’s Vulnerable › Vulnerabilities
CVE-2024-5998: Deserialization of Untrusted Data in langchain-ai/langchain
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-17 · updated 2026-06-17
- Weakness: CWE-502
Description
A vulnerability in the FAISS.deserialize_from_bytes function of langchain-ai/langchain allows for pickle deserialization of untrusted data. This can lead to the execution of arbitrary commands via the os.system function. The issue affects the latest version of the product.
Affected products
- langchain-ai/langchain: before 0.2.9 — fixed in 0.2.9
How to fix
Upgrade to a fixed version: langchain-ai/langchain 0.2.9. Check the vendor advisory for mitigations.
References
- https://github.com/langchain-ai/langchain/commit/604dfe2d99246b0c09f047c604f0c63eafba31e7
- https://huntr.com/bounties/fa3a2753-57c3-4e08-a176-d7a3ffda28fe
Get alerted when CVE-2024-5998 or the next vulnerability affects your stack