What’s Vulnerable › Vulnerabilities
CVE-2024-6000: FooEvents for WooCommerce <= 1.19.20 - Improper Authorization to (Contributor+) Arbitrary File Upload
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-15 · updated 2026-06-17
- Weakness: CWE-285
Description
The FooEvents for WooCommerce plugin for WordPress is vulnerable to unauthorized arbitrary file uploads due to an improper capability setting on the 'display_ticket_themes_page' function in versions up to, and including, 1.19.20. This makes it possible for authenticated attackers with contributor-level capabilities or above, to upload arbitrary files on the affected site's server which may make remote code execution possible. This was partially patched in 1.19.20, and fully patched in 1.19.21.
Affected products
- Fooevents: before 1.19.21 — fixed in 1.19.21
How to fix
Upgrade to a fixed version: Fooevents 1.19.21. Check the vendor advisory for mitigations.
References
- https://help.fooevents.com/docs/topics/changelogs/fooevents-for-woocommerce/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1080810b-ec9a-44fb-b4da-49b28646a441?source=cve
- https://help.fooevents.com/docs/topics/changelogs/fooevents-for-woocommerce/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1080810b-ec9a-44fb-b4da-49b28646a441?source=cve
Get alerted when CVE-2024-6000 or the next vulnerability affects your stack