What’s Vulnerable › Vulnerabilities
CVE-2024-6022: ContentLock <= 1.0.3 - Settings Update via CSRF
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-12 · updated 2026-06-17
- Weakness: CWE-352
Description
The ContentLock WordPress plugin through 1.0.3 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF attack
Affected products
- ContentLock: before 1.0.4 — fixed in 1.0.4
How to fix
Upgrade to a fixed version: ContentLock 1.0.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/871a93b5-ec67-4fe0-bc39-e5485477fbeb/
- https://wpscan.com/vulnerability/871a93b5-ec67-4fe0-bc39-e5485477fbeb/
Get alerted when CVE-2024-6022 or the next vulnerability affects your stack