What’s Vulnerable › Vulnerabilities
CVE-2024-6024: ContentLock <= 1.0.3 - Groups/Emails Deletion via CSRF
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-12 · updated 2026-06-17
- Weakness: CWE-352
Description
The ContentLock WordPress plugin through 1.0.3 does not have CSRF check in place when deleting groups or emails, which could allow attackers to make a logged in admin remove them via a CSRF attack
Affected products
- ContentLock: before 1.0.4 — fixed in 1.0.4
How to fix
Upgrade to a fixed version: ContentLock 1.0.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3d2cdb4f-b7e1-4691-90d1-cddde7f5858e/
- https://wpscan.com/vulnerability/3d2cdb4f-b7e1-4691-90d1-cddde7f5858e/
Get alerted when CVE-2024-6024 or the next vulnerability affects your stack