What’s Vulnerable › Vulnerabilities
CVE-2024-6025: Quiz and Survey Master < 9.0.5 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The Quiz and Survey Master (QSM) WordPress plugin before 9.0.5 does not sanitise and escape some of its Quiz settings, which could allow contributors and higher to perform Stored Cross-Site Scripting attacks
Affected products
- ExpressTech Quiz And Survey Master: before 9.0.5 — fixed in 9.0.5
How to fix
Upgrade to a fixed version: ExpressTech Quiz And Survey Master 9.0.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/15abc7dd-95b1-4dad-ba25-eb65105d3925/
- https://wpscan.com/vulnerability/15abc7dd-95b1-4dad-ba25-eb65105d3925/
Get alerted when CVE-2024-6025 or the next vulnerability affects your stack