What’s Vulnerable › Vulnerabilities
CVE-2024-6072: WP eStore < 8.5.5 - Reflected XSS via $_SERVER['REQUEST_URI']
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The wp-cart-for-digital-products WordPress plugin before 8.5.5 does not escape the $_SERVER['REQUEST_URI'] parameter before outputting it back in an attribute, which could lead to Reflected Cross-Site Scripting in old web browsers
Affected products
- wp-cart-for-digital-products: before 8.5.5 — fixed in 8.5.5
How to fix
Upgrade to a fixed version: wp-cart-for-digital-products 8.5.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/1d8a344b-37e9-41e8-9de0-c67b7ca8e21b/
- https://wpscan.com/vulnerability/1d8a344b-37e9-41e8-9de0-c67b7ca8e21b/
Get alerted when CVE-2024-6072 or the next vulnerability affects your stack