What’s Vulnerable › Vulnerabilities
CVE-2024-6087: Improper Access Control in lunary-ai/lunary
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-13 · updated 2026-06-17
- Weakness: CWE-639
Description
An improper access control vulnerability exists in lunary-ai/lunary at the latest commit (a761d83) on the main branch. The vulnerability allows an attacker to use the auth tokens issued by the 'invite user' functionality to obtain valid JWT tokens. These tokens can be used to compromise target users upon registration for their own arbitrary organizations. The attacker can invite a target email, obtain a one-time use token, retract the invite, and later use the token to reset the password of the target user, leading to full account takeover.
Affected products
- lunary-ai/lunary: before 1.4.9 — fixed in 1.4.9
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.4.9. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/844e8855c7a713dc7371766dba4125de4007b1cf
- https://huntr.com/bounties/bd9f2301-11c7-4cbd-8d77-3e9225bd67e8
Get alerted when CVE-2024-6087 or the next vulnerability affects your stack