What’s Vulnerable › Vulnerabilities
CVE-2024-6107
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-21 · updated 2026-06-17
- Weakness: CWE-287
Description
Due to insufficient verification, an attacker could use a malicious client to bypass authentication checks and run RPC commands in a region. This has been addressed in MAAS and updated in the corresponding snaps.
Affected products
- Canonical Metal As A Service: from 3.1.0 before 3.1.4; from 3.2.0 before 3.2.11; from 3.3.0 before 3.3.8; from 3.4.0 before 3.4.4; 3.5.0 — fixed in 3.1.4, 3.2.11, 3.3.8, 3.4.4
How to fix
Upgrade to a fixed version: Canonical Metal As A Service 3.1.4, 3.2.11, 3.3.8, 3.4.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6107 or the next vulnerability affects your stack