What’s Vulnerable › Vulnerabilities
CVE-2024-6127: BC Security Empire Path Traversal RCE
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-27 · updated 2026-07-14
- Weakness: CWE-22
Description
BC Security Empire before 5.9.3 is vulnerable to a path traversal issue that can lead to remote code execution. A remote, unauthenticated attacker can exploit this vulnerability over HTTP by acting as a normal agent, completing all cryptographic handshakes, and then triggering an upload of payload data containing a malicious path.
Affected products
- Bcsecurity Empire: before 5.9.3 — fixed in 5.9.3
How to fix
Upgrade to a fixed version: Bcsecurity Empire 5.9.3. Check the vendor advisory for mitigations.
References
- https://aceresponder.com/blog/exploiting-empire-c2-framework
- https://github.com/ACE-Responder/Empire-C2-RCE-PoC
- https://github.com/BC-SECURITY/Empire/blob/8283bbc77250232eb493bf1f9104fdd0d468962a/CHANGELOG.md?plain=1#L102
- https://vulncheck.com/advisories/empire-unauth-rce
- https://aceresponder.com/blog/exploiting-empire-c2-framework
- https://github.com/ACE-Responder/Empire-C2-RCE-PoC
- https://github.com/BC-SECURITY/Empire/blob/8283bbc77250232eb493bf1f9104fdd0d468962a/CHANGELOG.md?plain=1#L102
- https://vulncheck.com/advisories/empire-unauth-rce
Get alerted when CVE-2024-6127 or the next vulnerability affects your stack