What’s Vulnerable › Vulnerabilities
CVE-2024-6153: Parallels Desktop Updater Protection Mechanism Failure Software Downgrade Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-20 · updated 2026-06-17
- Weakness: CWE-693
Description
Parallels Desktop Updater Protection Mechanism Failure Software Downgrade Vulnerability. This vulnerability allows local attackers to downgrade Parallels software on affected installations of Parallels Desktop. An attacker must first obtain the ability to execute low-privileged code on the target host system in order to exploit this vulnerability. The specific flaw exists within the Updater service. The issue results from the lack of proper validation of version information before performing an update. An attacker can leverage this in conjunction with other vulnerabilities to escalate privileges and execute arbitrary code in the context of root. Was ZDI-CAN-19481.
Affected products
- Parallels Desktop: before 18.1.0 — fixed in 18.1.0
How to fix
Upgrade to a fixed version: Parallels Desktop 18.1.0. Check the vendor advisory for mitigations.
References
- https://www.zerodayinitiative.com/advisories/ZDI-24-803/
- https://www.zerodayinitiative.com/advisories/ZDI-24-803/
Get alerted when CVE-2024-6153 or the next vulnerability affects your stack