What’s Vulnerable › Vulnerabilities
CVE-2024-6156
- Severity: low (CVSS 3.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-06 · updated 2026-06-17
- Weakness: CWE-295
Description
Mark Laing discovered that LXD's PKI mode, until version 5.21.2, could be bypassed if the client's certificate was present in the trust store.
Affected products
- Canonical LXD: from 4.0.0 before 4.0.10; from 5.0.0 before 5.0.4; from 5.1 before 5.21.2 — fixed in 4.0.10, 5.0.4, 5.21.2
How to fix
Upgrade to a fixed version: Canonical LXD 4.0.10, 5.0.4, 5.21.2. Check the vendor advisory for mitigations.
References
- https://github.com/canonical/lxd/security/advisories/GHSA-4c49-9fpc-hc3v
- https://www.cve.org/CVERecord?id=CVE-2024-6156
Get alerted when CVE-2024-6156 or the next vulnerability affects your stack