What’s Vulnerable › Vulnerabilities
CVE-2024-6158: Category Posts Widget (Free < 4.9.17, Pro < 4.9.13) - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The Category Posts Widget WordPress plugin before 4.9.17, term-and-category-based-posts-widget WordPress plugin before 4.9.13 does not validate and escape some of its "Category Posts" widget settings before outputting them back in a page/post where the Widget is embed, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Tiptoppress Term And Category Based Posts Widget: before 4.9.13 — fixed in 4.9.13
- Category Posts Widget: before 4.9.17 — fixed in 4.9.17
How to fix
Upgrade to a fixed version: Tiptoppress Term And Category Based Posts Widget 4.9.13; Category Posts Widget 4.9.17. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6158 or the next vulnerability affects your stack