What’s Vulnerable › Vulnerabilities
CVE-2024-6159: Push Notification for Post and BuddyPress <=1.93 - Multiple Unauthenticated SQLi
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-89
Description
The Push Notification for Post and BuddyPress WordPress plugin before 1.9.4 does not properly sanitise and escape a parameter before using it in a SQL statement via an AJAX action available to unauthenticated users, leading to a SQL injection
Affected products
- Push Notification for Post and BuddyPress: before 1.9.4 — fixed in 1.9.4
How to fix
Upgrade to a fixed version: Push Notification for Post and BuddyPress 1.9.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/de20ebda-b0bc-489e-a8d3-e9487a2b48e8/
- https://wpscan.com/vulnerability/de20ebda-b0bc-489e-a8d3-e9487a2b48e8/
Get alerted when CVE-2024-6159 or the next vulnerability affects your stack