What’s Vulnerable › Vulnerabilities
CVE-2024-6164: Filter & Grids < 2.8.33 - Unauthenticated LFI
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-18 · updated 2026-06-17
- Weakness: CWE-22
Description
The Filter & Grids WordPress plugin before 2.8.33 is vulnerable to Local File Inclusion via the post_layout parameter. This makes it possible for an unauthenticated attacker to include and execute PHP files on the server, allowing the execution of any PHP code in those files.
Affected products
- Filter & Grids: before 2.8.33 — fixed in 2.8.33
How to fix
Upgrade to a fixed version: Filter & Grids 2.8.33. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/40bd880e-67a1-4180-b197-8dcadaa0ace4/
- https://wpscan.com/vulnerability/40bd880e-67a1-4180-b197-8dcadaa0ace4/
Get alerted when CVE-2024-6164 or the next vulnerability affects your stack