What’s Vulnerable › Vulnerabilities
CVE-2024-6219
- Severity: low (CVSS 3.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-06 · updated 2026-06-17
- Weakness: CWE-295
Description
Mark Laing discovered in LXD's PKI mode, until version 5.21.1, that a restricted certificate could be added to the trust store with its restrictions not honoured.
Affected products
- Canonical LXD: before 5.21.1 — fixed in 5.21.1
How to fix
Upgrade to a fixed version: Canonical LXD 5.21.1. Check the vendor advisory for mitigations.
References
- https://github.com/canonical/lxd/security/advisories/GHSA-jpmc-7p9c-4rxf
- https://www.cve.org/CVERecord?id=CVE-2024-6219
Get alerted when CVE-2024-6219 or the next vulnerability affects your stack