What’s Vulnerable › Vulnerabilities

CVE-2024-6225: Amelia <= 1.1.5 & Amelia (Pro) <= 7.5.1 - Authenticated (Admin+) Stored Cross-Site Scripting

Description

The Booking for Appointments and Events Calendar – Amelia plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 1.1.5 (and 7.5.1 for the Pro version) due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

Affected products

How to fix

Upgrade to a fixed version: TMS Amelia 1.1.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-6225 or the next vulnerability affects your stack