What’s Vulnerable › Vulnerabilities
CVE-2024-6231: Request a Quote < 2.4.1 - Admin+ Stored XSS
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-23 · updated 2026-06-17
- Weakness: CWE-79
Description
The Request a Quote WordPress plugin before 2.4.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Request a Quote: before 2.4.1 — fixed in 2.4.1
How to fix
Upgrade to a fixed version: Request a Quote 2.4.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/75ad1d8f-edc3-4eb3-b4c0-73832c0a4ca0/
- https://wpscan.com/vulnerability/75ad1d8f-edc3-4eb3-b4c0-73832c0a4ca0/
Get alerted when CVE-2024-6231 or the next vulnerability affects your stack