What’s Vulnerable › Vulnerabilities
CVE-2024-6238: pgAdmin 4 Installation Directory permission issue
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-25 · updated 2026-06-17
- Weakness: CWE-276
Description
pgAdmin <= 8.8 has an installation Directory permission issue. Because of this issue, attackers can gain unauthorised access to the installation directory on the Debian or RHEL 8 platforms.
Affected products
- pgadmin.org pgAdmin 4: before 8.9 — fixed in 8.9
How to fix
Upgrade to a fixed version: pgadmin.org pgAdmin 4 8.9. Check the vendor advisory for mitigations.
References
- https://github.com/pgadmin-org/pgadmin4/issues/7605
- https://github.com/pgadmin-org/pgadmin4/issues/7605
Get alerted when CVE-2024-6238 or the next vulnerability affects your stack