What’s Vulnerable › Vulnerabilities
CVE-2024-6239: Poppler: pdfinfo: crash in broken documents when using -dests parameter
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-21 · updated 2026-06-17
- Weakness: CWE-20
Description
A flaw was found in the Poppler's Pdfinfo utility. This issue occurs when using -dests parameter with pdfinfo utility. By using certain malformed input files, an attacker could cause the utility to crash, leading to a denial of service.
Affected products
- poppler: before 24.06.0 — fixed in 24.06.0
- Red Hat Enterprise Linux: 7.0, 8.0, 9.0
How to fix
Upgrade to a fixed version: poppler 24.06.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2024:5305
- https://access.redhat.com/errata/RHSA-2024:9167
- https://access.redhat.com/security/cve/CVE-2024-6239
- https://bugzilla.redhat.com/show_bug.cgi?id=2293594
- https://access.redhat.com/security/cve/CVE-2024-6239
- https://bugzilla.redhat.com/show_bug.cgi?id=2293594
Get alerted when CVE-2024-6239 or the next vulnerability affects your stack