What’s Vulnerable › Vulnerabilities
CVE-2024-6243: HTML Forms < 1.3.33 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The HTML Forms WordPress plugin before 1.3.33 does not sanitize and escape the form message inputs, allowing high-privilege users, such as administrators, to perform Stored Cross-Site Scripting (XSS) attacks even when the unfiltered_html capability is disabled.
Affected products
- HTML Forms: before 1.3.33 — fixed in 1.3.33
How to fix
Upgrade to a fixed version: HTML Forms 1.3.33. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/f4097877-ba19-4738-a994-9593b9a5a635/
- https://wpscan.com/vulnerability/f4097877-ba19-4738-a994-9593b9a5a635/
Get alerted when CVE-2024-6243 or the next vulnerability affects your stack