What’s Vulnerable › Vulnerabilities
CVE-2024-6247: Wyze Cam v3 Wi-Fi SSID OS Command Injection Remote Code Execution Vulnerability
- Severity: medium (CVSS 6.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-22 · updated 2026-06-17
- Weakness: CWE-78
Description
Wyze Cam v3 Wi-Fi SSID OS Command Injection Remote Code Execution Vulnerability. This vulnerability allows physically present attackers to execute arbitrary code on affected installations of Wyze Cam v3 IP cameras. Authentication is not required to exploit this vulnerability. The specific flaw exists within the handling of SSIDs embedded in scanned QR codes. The issue results from the lack of proper validation of a user-supplied string before using it to execute a system call. An attacker can leverage this vulnerability to execute code in the context of root. Was ZDI-CAN-22337.
Affected products
- Wyze Cam v3: before 4.36.11.8391 — fixed in 4.36.11.8391
How to fix
Upgrade to a fixed version: Wyze Cam v3 4.36.11.8391. Check the vendor advisory for mitigations.
References
- https://forums.wyze.com/t/security-advisory/289256
- https://www.zerodayinitiative.com/advisories/ZDI-24-838/
Get alerted when CVE-2024-6247 or the next vulnerability affects your stack