What’s Vulnerable › Vulnerabilities
CVE-2024-6248: Wyze Cam v3 Cloud Infrastructure Improper Authentication Remote Code Execution Vulnerability
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-22 · updated 2026-06-17
- Weakness: CWE-287
Description
Wyze Cam v3 Cloud Infrastructure Improper Authentication Remote Code Execution Vulnerability. This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of Wyze Cam v3 IP cameras. Authentication is not required to exploit this vulnerability. The specific flaw exists within the run_action_batch endpoint of the cloud infrastructure. The issue results from the use of the device's MAC address as a sole credential for authentication. An attacker can leverage this in conjunction with other vulnerabilities to execute arbitrary code in the context of root. Was ZDI-CAN-22393.
Affected products
- Wyze Cam v3: before 4.36.11.8391 — fixed in 4.36.11.8391
How to fix
Upgrade to a fixed version: Wyze Cam v3 4.36.11.8391. Check the vendor advisory for mitigations.
References
- https://forums.wyze.com/t/security-advisory/289256
- https://www.zerodayinitiative.com/advisories/ZDI-24-839/
Get alerted when CVE-2024-6248 or the next vulnerability affects your stack