What’s Vulnerable › Vulnerabilities
CVE-2024-6256: Feeds for YouTube (YouTube video, channel, and gallery plugin) <= 2.2.1 - Authenticated (Contributor+) DOM-Based Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The Feeds for YouTube (YouTube video, channel, and gallery plugin) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'youtube-feed' shortcode in all versions up to, and including, 2.2.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- smub Feeds for YouTube (YouTube video, channel, and gallery plugin): before 2.2.2 — fixed in 2.2.2
How to fix
Upgrade to a fixed version: smub Feeds for YouTube (YouTube video, channel, and gallery plugin) 2.2.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/feeds-for-youtube/trunk/js/sb-youtube.js
- https://plugins.trac.wordpress.org/changeset/3107577/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/228fab65-e5c2-41d1-ad41-fac4862894f2?source=cve
- https://plugins.trac.wordpress.org/browser/feeds-for-youtube/trunk/js/sb-youtube.js
- https://plugins.trac.wordpress.org/changeset/3107577/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/228fab65-e5c2-41d1-ad41-fac4862894f2?source=cve
Get alerted when CVE-2024-6256 or the next vulnerability affects your stack