What’s Vulnerable › Vulnerabilities
CVE-2024-6257: HashiCorp go-getter Vulnerable to Code Execution On Git Update Via Git Config Manipulation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-25 · updated 2026-06-17
- Weakness: CWE-77
Description
HashiCorp’s go-getter library can be coerced into executing Git update on an existing maliciously modified Git Configuration, potentially leading to arbitrary code execution.
Affected products
- HashiCorp go-getter: before 1.7.5 — fixed in 1.7.5
How to fix
Upgrade to a fixed version: HashiCorp go-getter 1.7.5. Check the vendor advisory for mitigations.
References
- https://discuss.hashicorp.com/t/hcsec-2024-13-hashicorp-go-getter-vulnerable-to-code-execution-on-git-update-via-git-config-manipulation/68081
- https://discuss.hashicorp.com/t/hcsec-2024-13-hashicorp-go-getter-vulnerable-to-code-execution-on-git-update-via-git-config-manipulation/68081
Get alerted when CVE-2024-6257 or the next vulnerability affects your stack