What’s Vulnerable › Vulnerabilities
CVE-2024-6264: Post Meta Data Manager <= 1.2.3 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The Post Meta Data Manager plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘$meta_key’ parameter in all versions up to, and including, 1.2.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- gandhihitesh9 Post Meta Data Manager: before 1.3.0 — fixed in 1.3.0
How to fix
Upgrade to a fixed version: gandhihitesh9 Post Meta Data Manager 1.3.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/post-meta-data-manager/trunk/includes/admin/html/pmdm_wp_display_post_metadata_html.php#L23
- https://plugins.trac.wordpress.org/browser/post-meta-data-manager/trunk/includes/admin/html/pmdm_wp_display_term_metadata_html.php#L32
- https://plugins.trac.wordpress.org/browser/post-meta-data-manager/trunk/includes/admin/html/pmdm_wp_display_user_metadata_html.php#L31
- https://plugins.trac.wordpress.org/changeset/3109558/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9dd6828b-6235-4284-bce6-be23b79ac70e?source=cve
- https://plugins.trac.wordpress.org/browser/post-meta-data-manager/trunk/includes/admin/html/pmdm_wp_display_post_metadata_html.php#L23
- https://plugins.trac.wordpress.org/browser/post-meta-data-manager/trunk/includes/admin/html/pmdm_wp_display_term_metadata_html.php#L32
- https://plugins.trac.wordpress.org/browser/post-meta-data-manager/trunk/includes/admin/html/pmdm_wp_display_user_metadata_html.php#L31
- https://plugins.trac.wordpress.org/changeset/3109558/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9dd6828b-6235-4284-bce6-be23b79ac70e?source=cve
Get alerted when CVE-2024-6264 or the next vulnerability affects your stack