What’s Vulnerable › Vulnerabilities
CVE-2024-6271: Community Events < 1.5 - Event Deletion via CSRF
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-22 · updated 2026-06-17
- Weakness: CWE-352
Description
The Community Events WordPress plugin before 1.5 does not have CSRF check in place when deleting events, which could allow attackers to make a logged in admin delete arbitrary events via a CSRF attack
Affected products
- Community Events: before 1.5 — fixed in 1.5
How to fix
Upgrade to a fixed version: Community Events 1.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/44d9d085-34cb-490f-a3f5-f9eafae85ab8/
- https://wpscan.com/vulnerability/44d9d085-34cb-490f-a3f5-f9eafae85ab8/
Get alerted when CVE-2024-6271 or the next vulnerability affects your stack