What’s Vulnerable › Vulnerabilities
CVE-2024-6283: DethemeKit For Elementor <= 2.1.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via URL Parameter of the De Gallery Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The DethemeKit For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the URL parameter of the De Gallery widget in all versions up to and including 2.1.5 due to insufficient input sanitization and output escaping on user-supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user clicks on the injected link.
Affected products
- DethemeKit For Elementor: before 2.1.6 — fixed in 2.1.6
How to fix
Upgrade to a fixed version: DethemeKit For Elementor 2.1.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/dethemekit-for-elementor/trunk/widgets/dethemekit-grid.php#L2565
- https://plugins.trac.wordpress.org/browser/dethemekit-for-elementor/trunk/widgets/dethemekit-grid.php#L2900
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9b2083f9-79d0-43f6-b7ae-a5817dc561b0?source=cve
- https://plugins.trac.wordpress.org/browser/dethemekit-for-elementor/trunk/widgets/dethemekit-grid.php#L2565
- https://plugins.trac.wordpress.org/browser/dethemekit-for-elementor/trunk/widgets/dethemekit-grid.php#L2900
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9b2083f9-79d0-43f6-b7ae-a5817dc561b0?source=cve
Get alerted when CVE-2024-6283 or the next vulnerability affects your stack