What’s Vulnerable › Vulnerabilities
CVE-2024-6301: Origin Validation Error in Conduit
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-25 · updated 2026-06-17
- Weakness: CWE-346
Description
Lack of validation of origin in federation API in Conduit, allowing any remote server to impersonate any user from any server in most EDUs
Affected products
- The Conduit Contributors Conduit: before 0.8.0 — fixed in 0.8.0
How to fix
Upgrade to a fixed version: The Conduit Contributors Conduit 0.8.0. Check the vendor advisory for mitigations.
References
- https://conduit.rs/changelog/#v0-8-0-2024-06-12
- https://gitlab.com/famedly/conduit/-/releases/v0.8.0
- https://conduit.rs/changelog/#v0-8-0-2024-06-12
- https://gitlab.com/famedly/conduit/-/releases/v0.8.0
Get alerted when CVE-2024-6301 or the next vulnerability affects your stack