What’s Vulnerable › Vulnerabilities
CVE-2024-6318: IMGspider <= 2.3.10 - Authenticated (Contributor+) Arbitrary File Upload via 'upload_img_file'
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-04 · updated 2026-06-17
- Weakness: CWE-434
Description
The IMGspider plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'upload_img_file' function in all versions up to, and including, 2.3.10. This makes it possible for authenticated attackers, with contributor-level and above permissions, to upload arbitrary files on the affected site's server which may make remote code execution possible.
Affected products
- wbolt IMGspider – 图片采集抓取插件: before 2.3.11 — fixed in 2.3.11
How to fix
Upgrade to a fixed version: wbolt IMGspider – 图片采集抓取插件 2.3.11. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/imgspider/tags/2.3.10/classes/post.class.php#L122
- https://plugins.trac.wordpress.org/changeset/3107741/imgspider
- https://www.wordfence.com/threat-intel/vulnerabilities/id/306f00e4-9a70-48be-a91e-e396643a8129?source=cve
- https://plugins.trac.wordpress.org/browser/imgspider/tags/2.3.10/classes/post.class.php#L122
- https://plugins.trac.wordpress.org/changeset/3107741/imgspider
- https://www.wordfence.com/threat-intel/vulnerabilities/id/306f00e4-9a70-48be-a91e-e396643a8129?source=cve
Get alerted when CVE-2024-6318 or the next vulnerability affects your stack