What’s Vulnerable › Vulnerabilities
CVE-2024-6328: MStore API – Create Native Android & iOS Apps On The Cloud <= 4.14.7 - Authentication Bypass
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-12 · updated 2026-06-17
- Weakness: CWE-288
Description
The MStore API – Create Native Android & iOS Apps On The Cloud plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 4.14.7. This is due to insufficient verification on the 'phone' parameter of the 'firebase_sms_login' and 'firebase_sms_login_v2' functions. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they have access to the email address or phone number. Additionally, if a new email address is supplied, a new user account is created with the default role, even if registration is disabled.
Affected products
- inspireui MStore API – Create Native Android & iOS Apps On The Cloud: before 4.15.0 — fixed in 4.15.0
How to fix
Upgrade to a fixed version: inspireui MStore API – Create Native Android & iOS Apps On The Cloud 4.15.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/mstore-api/trunk/controllers/flutter-user.php#L699
- https://plugins.trac.wordpress.org/browser/mstore-api/trunk/controllers/flutter-user.php#L714
- https://plugins.trac.wordpress.org/changeset/3115231/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/17d8e2e9-5e3f-433b-be1a-6ea765eba547?source=cve
- https://plugins.trac.wordpress.org/browser/mstore-api/trunk/controllers/flutter-user.php#L699
- https://plugins.trac.wordpress.org/browser/mstore-api/trunk/controllers/flutter-user.php#L714
- https://plugins.trac.wordpress.org/changeset/3115231/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/17d8e2e9-5e3f-433b-be1a-6ea765eba547?source=cve
Get alerted when CVE-2024-6328 or the next vulnerability affects your stack