What’s Vulnerable › Vulnerabilities
CVE-2024-6329: Improper Encoding or Escaping of Output in GitLab
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-08 · updated 2026-06-17
- Weakness: CWE-116
Description
An issue was discovered in GitLab CE/EE affecting all versions starting from 8.16 prior to 17.0.6, starting from 17.1 prior to 17.1.4, and starting from 17.2 prior to 17.2.2, which causes the web interface to fail to render the diff correctly when the path is encoded.
Affected products
- GitLab: from 8.16.0 before 17.0.6; from 17.1.0 before 17.1.4; from 17.2.0 before 17.2.2 — fixed in 17.0.6, 17.1.4, 17.2.2
How to fix
Upgrade to a fixed version: GitLab 17.0.6, 17.1.4, 17.2.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6329 or the next vulnerability affects your stack