What’s Vulnerable › Vulnerabilities

CVE-2024-6336: Security misconfiguration was identified in GitHub Enterprise Server that allowed sensitive data exposure

Description

A Security Misconfiguration vulnerability in GitHub Enterprise Server allowed sensitive information disclosure to unauthorized users in GitHub Enterprise Server by exploiting organization ruleset feature. This attack required an organization member to explicitly change the visibility of a dependent repository from private to public. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in versions 3.13.1, 3.12.6, 3.11.12, 3.10.14, and 3.9.17. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products

How to fix

Upgrade to a fixed version: GitHub Enterprise Server 3.10.14, 3.11.12, 3.12.6, 3.9.17. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-6336 or the next vulnerability affects your stack