What’s Vulnerable › Vulnerabilities
CVE-2024-6337: Incorrect Authorization allows read access to issues in GitHub Enterprise Server
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-20 · updated 2026-06-17
- Weakness: CWE-863
Description
An Incorrect Authorization vulnerability was identified in GitHub Enterprise Server that allowed a GitHub App with only content: read and pull_request_write: write permissions to read issue content inside a private repository. This was only exploitable via user access token and installation access token was not impacted. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in versions 3.13.3, 3.12.8, 3.11.14 and 3.10.16. This vulnerability was reported via the GitHub Bug Bounty program.
Affected products
- GitHub Enterprise Server: from 3.10.0 before 3.10.16; from 3.11.0 before 3.11.14; from 3.12.0 before 3.12.8; from 3.13.0 before 3.13.3 — fixed in 3.10.16, 3.11.14, 3.12.8, 3.13.3
How to fix
Upgrade to a fixed version: GitHub Enterprise Server 3.10.16, 3.11.14, 3.12.8, 3.13.3. Check the vendor advisory for mitigations.
References
- https://docs.github.com/en/enterprise-server@3.10/admin/release-notes#3.10.16
- https://docs.github.com/en/enterprise-server@3.11/admin/release-notes#3.11.14
- https://docs.github.com/en/enterprise-server@3.12/admin/release-notes#3.12.8
- https://docs.github.com/en/enterprise-server@3.13/admin/release-notes#3.13.3
Get alerted when CVE-2024-6337 or the next vulnerability affects your stack