What’s Vulnerable › Vulnerabilities
CVE-2024-6338: FV Player <= 7.5.46.7212 - Authenticated (Subscriber+) SQL Injection via exclude Parameter
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-19 · updated 2026-06-17
- Weakness: CWE-89
Description
The FV Flowplayer Video Player plugin for WordPress is vulnerable to time-based SQL Injection via the ‘exclude’ parameter in all versions up to, and including, 7.5.46.7212 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Affected products
- foliovision FV Flowplayer Video Player: before 7.5.47.7212 — fixed in 7.5.47.7212
How to fix
Upgrade to a fixed version: foliovision FV Flowplayer Video Player 7.5.47.7212. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/fv-wordpress-flowplayer/trunk/models/video-encoder/class.fv-player-encoder-list-table.php#L308
- https://plugins.trac.wordpress.org/changeset/3121532/
- https://wordpress.org/plugins/fv-wordpress-flowplayer/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d4185a0e-d944-408f-8a43-8f9c6bc3964d?source=cve
- https://plugins.trac.wordpress.org/browser/fv-wordpress-flowplayer/trunk/models/video-encoder/class.fv-player-encoder-list-table.php#L308
- https://plugins.trac.wordpress.org/changeset/3121532/
- https://wordpress.org/plugins/fv-wordpress-flowplayer/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d4185a0e-d944-408f-8a43-8f9c6bc3964d?source=cve
Get alerted when CVE-2024-6338 or the next vulnerability affects your stack