What’s Vulnerable › Vulnerabilities

CVE-2024-6343

Description

A buffer overflow vulnerability in the CGI program of Zyxel ATP series firmware versions from V4.32 through V5.38, USG FLEX series firmware versions from V4.50 through V5.38, USG FLEX 50(W) series firmware versions from V4.16 through V5.38, and USG20(W)-VPN series firmware versions from V4.16 through V5.38 could allow an authenticated attacker with administrator privileges to cause denial of service (DoS) conditions by sending a crafted HTTP request to a vulnerable device.

Affected products

How to fix

Upgrade to a fixed version: Zyxel firewall (ZLD) 5.39. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-6343 or the next vulnerability affects your stack