What’s Vulnerable › Vulnerabilities
CVE-2024-6364: Server Identity Validation Bypass in Absolute Persistence®
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-13 · updated 2026-06-17
- Weakness: CWE-284
Description
A vulnerability in Absolute Persistence® versions before 2.8 exists when it is not activated. This may allow a skilled attacker with both physical access to the device, and full hostile network control, to initiate OS commands on the device. To remediate this vulnerability, update the device firmware to the latest available version. Please contact the device manufacturer for upgrade instructions or contact Absolute Security, see reference below.
Affected products
- Absolute Security Absolute Persistence: before 2.8 — fixed in 2.8
How to fix
Upgrade to a fixed version: Absolute Security Absolute Persistence 2.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6364 or the next vulnerability affects your stack