What’s Vulnerable › Vulnerabilities
CVE-2024-6376: ejson shell parser in MongoDB Compass maybe bypassed
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-01 · updated 2026-06-17
- Weakness: CWE-20
Description
MongoDB Compass may be susceptible to code injection due to insufficient sandbox protection settings with the usage of ejson shell parser in Compass' connection handling. This issue affects MongoDB Compass versions prior to version 1.42.2
Affected products
- MongoDB Compass: before 1.42.2 — fixed in 1.42.2
How to fix
Upgrade to a fixed version: MongoDB Compass 1.42.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6376 or the next vulnerability affects your stack