What’s Vulnerable › Vulnerabilities
CVE-2024-6382: Adversarial unsanitized input may cause MongoDB Rust Driver to issue unintended commands.
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-02 · updated 2026-06-17
- Weakness: CWE-228
Description
Incorrect handling of certain string inputs may result in MongoDB Rust driver constructing unintended server commands. This may cause unexpected application behavior including data modification. This issue affects MongoDB Rust Driver 2.0 versions prior to 2.8.2
Affected products
- MongoDB Rust Driver: from 2.0.0 before 2.8.2 — fixed in 2.8.2
How to fix
Upgrade to a fixed version: MongoDB Rust Driver 2.8.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-6382 or the next vulnerability affects your stack