What’s Vulnerable › Vulnerabilities
CVE-2024-6385: Improper Access Control in GitLab
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-11 · updated 2026-06-17
- Weakness: CWE-284
Description
An issue was discovered in GitLab CE/EE affecting all versions starting from 15.8 prior to 16.11.6, starting from 17.0 prior to 17.0.4, and starting from 17.1 prior to 17.1.2, which allows an attacker to trigger a pipeline as another user under certain circumstances.
Affected products
- GitLab: from 15.8.0 before 16.11.6; from 17.0.0 before 17.0.4; from 17.1.0 before 17.1.2 — fixed in 16.11.6, 17.0.4, 17.1.2
How to fix
Upgrade to a fixed version: GitLab 16.11.6, 17.0.4, 17.1.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/469217
- https://hackerone.com/reports/2578672
- https://gitlab.com/gitlab-org/gitlab/-/issues/469217
- https://hackerone.com/reports/2578672
Get alerted when CVE-2024-6385 or the next vulnerability affects your stack